return $abbr ? Text::_('WED') : Text::_('WEDNESDAY'); case 4: return $abbr ? Text::_('THU') : Text::_('THURSDAY'); case 5: return $abbr ? Text::_('FRI') : Text::_('FRIDAY'); case 6: return $abbr ? Text::_('SAT') : Text::_('SATURDAY'); } return ''; } /** * Gets the date as a formatted string in a local calendar. * * @param string $format The date format specification string (see {@link PHP_MANUAL#date}) * @param boolean $local True to return the date string in the local time zone, false to return it in GMT. * @param boolean $translate True to translate localised strings * * @return string The date string in the specified format format. * * @since 1.7.0 */ public function calendar($format, $local = false, $translate = true) { return $this->format($format, $local, $translate); } /** * Gets the date as a formatted string. * * @param string $format The date format specification string (see {@link PHP_MANUAL#date}) * @param boolean $local True to return the date string in the local time zone, false to return it in GMT. * @param boolean $translate True to translate localised strings * * @return string The date string in the specified format format. * * @since 1.7.0 */ public function format($format, $local = false, $translate = true): string { if ($translate) { // Do string replacements for date format options that can be translated. $format = preg_replace('/(^|[^\\\])D/', "\\1" . self::DAY_ABBR, $format); $format = preg_replace('/(^|[^\\\])l/', "\\1" . self::DAY_NAME, $format); $format = preg_replace('/(^|[^\\\])M/', "\\1" . self::MONTH_ABBR, $format); $format = preg_replace('/(^|[^\\\])F/', "\\1" . self::MONTH_NAME, $format); } // If the returned time should not be local use UTC. if ($local == false) { parent::setTimezone(new \DateTimeZone('UTC')); } // Format the date. $return = parent::format($format); if ($translate) { // Manually modify the month and day strings in the formatted time. if (str_contains($return, self::DAY_ABBR)) { $return = str_replace(self::DAY_ABBR, $this->dayToString(parent::format('w'), true), $return); } if (str_contains($return, self::DAY_NAME)) { $return = str_replace(self::DAY_NAME, $this->dayToString(parent::format('w')), $return); } if (str_contains($return, self::MONTH_ABBR)) { $return = str_replace(self::MONTH_ABBR, $this->monthToString(parent::format('n'), true), $return); } if (str_contains($return, self::MONTH_NAME)) { $return = str_replace(self::MONTH_NAME, $this->monthToString(parent::format('n')), $return); } } if ($local == false && $this->tz !== null) { parent::setTimezone($this->tz); } return $return; } /** * Get the time offset from GMT in hours or seconds. * * @param boolean $hours True to return the value in hours. * * @return float The time offset from GMT either in hours or in seconds. * * @since 1.7.0 */ public function getOffsetFromGmt($hours = false) { return (float) $hours ? ($this->tz->getOffset($this) / 3600) : $this->tz->getOffset($this); } /** * Translates month number to a string. * * @param integer $month The numeric month of the year. * @param boolean $abbr If true, return the abbreviated month string * * @return string The month of the year. * * @since 1.7.0 */ public function monthToString($month, $abbr = false) { switch ($month) { case 1: return $abbr ? Text::_('JANUARY_SHORT') : Text::_('JANUARY'); case 2: return $abbr ? Text::_('FEBRUARY_SHORT') : Text::_('FEBRUARY'); case 3: return $abbr ? Text::_('MARCH_SHORT') : Text::_('MARCH'); case 4: return $abbr ? Text::_('APRIL_SHORT') : Text::_('APRIL'); case 5: return $abbr ? Text::_('MAY_SHORT') : Text::_('MAY'); case 6: return $abbr ? Text::_('JUNE_SHORT') : Text::_('JUNE'); case 7: return $abbr ? Text::_('JULY_SHORT') : Text::_('JULY'); case 8: return $abbr ? Text::_('AUGUST_SHORT') : Text::_('AUGUST'); case 9: return $abbr ? Text::_('SEPTEMBER_SHORT') : Text::_('SEPTEMBER'); case 10: return $abbr ? Text::_('OCTOBER_SHORT') : Text::_('OCTOBER'); case 11: return $abbr ? Text::_('NOVEMBER_SHORT') : Text::_('NOVEMBER'); case 12: return $abbr ? Text::_('DECEMBER_SHORT') : Text::_('DECEMBER'); } return ''; } /** * Method to wrap the setTimezone() function and set the internal time zone object. * * @param \DateTimeZone $tz The new \DateTimeZone object. * * @return Date * * @since 1.7.0 * @note This method can't be type hinted due to a PHP bug: https://bugs.php.net/bug.php?id=61483 */ public function setTimezone($tz): \Datetime { $this->tz = $tz; return parent::setTimezone($tz); } /** * Gets the date as an ISO 8601 string. IETF RFC 3339 defines the ISO 8601 format * and it can be found at the IETF Web site. * * @param boolean $local True to return the date string in the local time zone, false to return it in GMT. * * @return string The date string in ISO 8601 format. * * @link http://www.ietf.org/rfc/rfc3339.txt * @since 1.7.0 */ public function toISO8601($local = false) { return $this->format(\DateTimeInterface::RFC3339, $local, false); } /** * Gets the date as an SQL datetime string. * * @param boolean $local True to return the date string in the local time zone, false to return it in GMT. * @param ?DatabaseDriver $db The database driver or null to use Factory::getDbo() * * @return string The date string in SQL datetime format. * * @link http://dev.mysql.com/doc/refman/5.0/en/datetime.html * @since 2.5.0 */ public function toSql($local = false, ?DatabaseDriver $db = null) { if ($db === null) { $db = Factory::getDbo(); } return $this->format($db->getDateFormat(), $local, false); } /** * Gets the date as an RFC 822 string. IETF RFC 2822 supercedes RFC 822 and its definition * can be found at the IETF Web site. * * @param boolean $local True to return the date string in the local time zone, false to return it in GMT. * * @return string The date string in RFC 822 format. * * @link http://www.ietf.org/rfc/rfc2822.txt * @since 1.7.0 */ public function toRFC822($local = false) { return $this->format(\DateTimeInterface::RFC2822, $local, false); } /** * Gets the date as UNIX time stamp. * * @return integer The date as a UNIX timestamp. * * @since 1.7.0 */ public function toUnix() { return (int) parent::format('U'); } } Attempted to load class "Helper" from namespace "HelixUltimate\Framework\Platform". Did you forget a "use" statement for another namespace? (500 Whoops, looks like something went wrong.)

Error ClassNotFoundError

HTTP 500 Whoops, looks like something went wrong.

Attempted to load class "Helper" from namespace "HelixUltimate\Framework\Platform".
Did you forget a "use" statement for another namespace?

Exceptions 2

Symfony\Component\ErrorHandler\Error\ ClassNotFoundError

  1. use Joomla\CMS\Uri\Uri;
  2. use Joomla\CMS\Language\Text;
  3. $app = Factory::getApplication();
  4. $doc = Factory::getDocument();
  5. $template = Helper::loadTemplateData();
  6. $params = $template->params;
  7. $fontCSS = '';
  8. function addGoogleFont($fonts)
  9. {
  1.             // Store the file path
  2.             $this->_file = $directory . '/' . $filename;
  3.             // Get the file content
  4.             ob_start();
  5.             require $directory . '/' . $filename;
  6.             $contents = ob_get_clean();
  7.         }
  8.         return $contents;
  9.     }
  1.         $this->baseurl  = Uri::base(true);
  2.         $this->params   = $params['params'] ?? new Registry();
  3.         $this->template = $template;
  4.         // Load
  5.         $this->_template = $this->_loadTemplate($baseDir, $file);
  6.         return $this;
  7.     }
  8.     /**
  1.      *
  2.      * @since   1.7.0
  3.      */
  4.     public function parse($params = [])
  5.     {
  6.         return $this->_fetchTemplate($params)->_parseTemplate();
  7.     }
  8.     /**
  9.      * Outputs the template to the browser.
  10.      *
  1.     public function render($caching = false, $params = [])
  2.     {
  3.         $this->_caching = $caching;
  4.         if (empty($this->_template)) {
  5.             $this->parse($params);
  6.         }
  7.         if (\array_key_exists('csp_nonce', $params) && $params['csp_nonce'] !== null) {
  8.             $this->cspNonce = $params['csp_nonce'];
  9.         }
  1.         $this->debug = $params['debug'] ?? false;
  2.         $this->error = $this->_error;
  3.         $params['file'] = 'error.php';
  4.         return parent::render($cache, $params);
  5.     }
  6.     /**
  7.      * Render the backtrace
  8.      *
  1.                 'template'         => $template->template,
  2.                 'directory'        => JPATH_THEMES,
  3.                 'debug'            => JDEBUG,
  4.                 'csp_nonce'        => $app->get('csp_nonce'),
  5.                 'templateInherits' => $template->parent,
  6.                 'params'           => $template->params,
  7.             ]
  8.         );
  9.     }
  10. }
  1.                     'subject'  => $app,
  2.                     'document' => $renderer->getDocument(),
  3.                 ])
  4.             );
  5.             $data = $renderer->render($error);
  6.             // If nothing was rendered, just use the message from the Exception
  7.             if (empty($data)) {
  8.                 $data = $error->getMessage();
  9.             }
  1.      * @since   3.10.0
  2.      */
  3.     public static function handleException(\Throwable $error)
  4.     {
  5.         static::logException($error);
  6.         static::render($error);
  7.     }
  8.     /**
  9.      * Render the error page based on an exception.
  10.      *
ExceptionHandler::handleException() in /home/phdpezes/public_html/libraries/src/Application/CMSApplication.php (line 334)
  1.             );
  2.             // Trigger the onError event.
  3.             $this->dispatchEvent('onError', $event);
  4.             ExceptionHandler::handleException($event->getError());
  5.         }
  6.         // Trigger the onBeforeRespond event.
  7.         $this->dispatchEvent(
  8.             'onBeforeRespond',
CMSApplication->execute() in /home/phdpezes/public_html/includes/app.php (line 58)
  1. // Set the application as global app
  2. \Joomla\CMS\Factory::$application = $app;
  3. // Execute the application.
  4. $app->execute();
require_once('/home/phdpezes/public_html/includes/app.php') in /home/phdpezes/public_html/index.php (line 32)
  1.  * define() is used rather than "const" to not error for PHP 5.2 and lower
  2.  */
  3. define('_JEXEC', 1);
  4. // Run the application - All executable code should be triggered through this file
  5. require_once __DIR__ . '/includes/app.php';

Error

Class "Joomla\CMS\Date\Date" not found

  1.         return 200;
  2.     }
  3. }
  4. class fa_IRDate extends Date {
  5.     const DAY_NUMBER    = "\x027\x03";
  6.     const DAY_NUMBER2    = "\x030\x03";
  7.     const DAY_YEAR        = "\x032\x03";
  8.     const MONTH_ABBR    = "\x033\x03";
  9.     const MONTH_NAME    = "\x034\x03";
  1.         ksort($paths);
  2.         $path = reset($paths);
  3.         while (!class_exists($class) && $path) {
  4.             if (is_file($path)) {
  5.                 require_once $path;
  6.             }
  7.             $path = next($paths);
  8.         }
  1.      *
  2.      * @since   4.0.0
  3.      */
  4.     public function createLanguage($lang, $debug = false): Language
  5.     {
  6.         return new Language($lang, $debug);
  7.     }
  8. }
  1.      * @since   4.0.0
  2.      */
  3.     public function createLanguage($lang, $debug = false): Language
  4.     {
  5.         if (!isset(self::$languages[$lang . $debug])) {
  6.             self::$languages[$lang . $debug] = parent::createLanguage($lang, $debug);
  7.         }
  8.         return self::$languages[$lang . $debug];
  9.     }
  10. }
CachingLanguageFactory->createLanguage() in /home/phdpezes/public_html/libraries/src/Application/CMSApplication.php (line 783)
  1.         if (isset($options['language'])) {
  2.             $this->set('language', $options['language']);
  3.         }
  4.         // Build our language object
  5.         $lang = $this->getContainer()->get(LanguageFactoryInterface::class)->createLanguage($this->get('language'), $this->get('debug_lang'));
  6.         // Load the language to the API
  7.         $this->loadLanguage($lang);
  8.         // Register the language object with Factory